Style Editor

Point Symbol Editor
The Symbol Editor is used to create and edit small CAD graphic symbols
for use as markers for point and node elements when displaying geometric
objects (vector, CAD, shape, and TIN). You can create a symbol by adding
one or more graphic elements including lines, polylines, various geometric
shapes, and text. Closed-shape elements and text can be drawn in outline
only or filled, and can be assigned a fixed color or a variable color that can
be set to a different color in each style that uses the symbol. You can select
any element of a symbol to manually edit it, delete it, change its drawing
order, or rescale it. You can create a new symbol from a selected glyph in
a TrueType font or paste a glyph into an existing symbol. Symbols can be
saved to a style object, saved as text, or saved as a style query.
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from the Pattern menu to save a modified symbol with a new
name. After working with one symbol you can press the New
icon button to clear the drawing canvas to begin working on a
new symbol.

Drawing Canvas
The Symbol Editor is opened by choosing the Symbol style
option in the Point Style controls in the Style Editor window
and then pressing the Create or Edit Symbol icon button. The
Symbol Editor window is divided into several sections (see illustration above). The left side of the main window area is the
drawing canvas in which you draw or edit elements of the symbol. The right side of the window provides color controls for
choosing or creating a color for the current element and element controls for setting the thickness of lines and borders and
whether to fill a closed shape. The menus and icon buttons at
the top of the window allow you to open and save symbols, to
zoom the drawing canvas, to choose a drawing tool, and to apply editing operations.

New, Open, and Save
The Symbol Editor opens with a blank drawing canvas. If you
are creating a new symbol you can begin adding elements immediately. To open an existing symbol for editing press the
Open icon button (or choose Pattern / Open). This option opens
the Select Symbols window, which you can use to choose a
symbol from the current style object or from any of the provided symbol libraries (see the Technical Guide entitled
Creating Styles for Points). Press the Save icon button to save
the symbol to the current style object. If you have created a
new symbol from scratch, a Save As window opens for you to
provide a name for the symbol. If you are editing a symbol that
has already been saved to the style object, the Save button overwrites the previously-saved version. Use the Save As option

The default background color of the drawing canvas is black.
You can change the color by pressing the Background
pushbutton in the color controls, which opens a standard color
selection window from which you can choose a color from a
palette or design a custom color. The drawing canvas uses a
local x,y coordinate system with the coordinate origin (0,0) at
the center of the canvas. The View menu provides options to
change the zoom level of the canvas: Zoom In, Zoom Out,
Zoom 1X, and Full (zooms to the full extents of the symbol).

Color Controls
Use the color controls in the right half of the Symbol Editor to
choose a color to assign to a new or selected element in the
canvas. Left-click on a color tile in the palette to pick a fixed
color. The rectangle below the palette shows the currentlyselected color. If you open a symbol that includes colors not
found in the palette, you can add them by selecting an element
that uses the desired color and pressing the From Symbol
pushbutton. You can add other colors to the default palette by
clicking on one of the unassigned (gray) tiles in the lower portion of the palette, which activates the Adjust pushbutton.
Pressing this button opens a standard Select Color window that
you can use to select or design a custom color to add to the
palette. The custom color can then be selected from the palette
in the Symbol Editor window like any of the standard colors.
Instead of assigning a fixed color to a symbol element, you can
press the Variable pushbutton next to the palette (the word “Vari(continued)
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able” is then shown in the color sample area below the palette).
When the symbol is used in a style, any element set to the “variable” color is assigned the color currently set for the point style.
The same symbol can then be used for a number of different
styles that have different style colors.

Element Controls
The Element text field shows the type of drawing tool (e.g.,
segment, polygon) that is currently selected (if any). The Fill
toggle button applies to closed shapes and sets whether the shape
is filled with the selected color or drawn in outline. The Thickness field value sets the relative thickness of a line element or
the border of a closed shape element. The default value of 0.00
produces the thinnest available line width when the symbol is
rendered in a geospatial view, to a print, or to a raster.
When you turn on the Snap to Grid toggle, a grid of horizontal
and vertical guide lines is activated in the drawing canvas (see
illustration below). The distance between the grid lines is set
by the Snap Distance menu selection. When you draw in the
canvas, the components of the element you are drawing are
automatically snapped to the grid: the vertices of a line segment, polyline, or polygon, the sides of a rectangle, or the center
of a circle, ellipse, or arc element. The snap grid allows you to
more precisely set the position, shape, and size of each element
in the symbol.

After drawing a prospective element, you can reposition it and
change its shape before adding it. Left click and drag on a line
segment, polyline, or the inside of a closed shape to reposition
it. Left-click and drag the edge or perimeter of a closed shape
to resize it. Some graphics can be rotated as described below.
Left-click away from/outside of the tool graphic to clear it and
start over.
Segment: Use the Segment tool to add a 2-point line to the
symbol. Left-click in the canvas to place one endpoint and
drag to the desired endpoint position. Left-click and drag either endpoint (marked with an “x”) to resize the line. Hold
down the Shift key while dragging the segment to rotate it around
the farther endpoint.
Rectangle: Draw a box with the Rectangle tool by left-clicking in the canvas and dragging from one box corner to its
diagonally opposite corner. Drag any corner or side of the rectangle to resize it. Hold down the Shift key while dragging a
corner to rotate the box around the opposite corner.
Circle: Left-click to place the center of the circle and drag in
any direction to set the radius of the circle.
Circular Arc, Circular Arc Wedge, Circular Arc Chord: Use
these tools to draw a circular arc (segment of the perimeter of a
circle) or a closed arc wedge or arc chord shape. Left-click to
place the center of the circle and drag to set the radius. The arc,
wedge, and chord graphics are bounded by two radii which
you can drag to set the direction of the element and the angle
between the radii. Drag the perimeter of the arc to change the
radius size.
Ellipse: Draw an ellipse with vertical and horizontal radii.
Left-click to place the center of the ellipse and drag away from
it to set its size and shape. The horizontal and vertical components of the direction you drag set the relative lengths of the
horizontal and vertical radii of the ellipse. Hold down the Shift
key while dragging on the outer
end of a radius to rotate the ellipse.
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Drawing Tools
You can activate any of the drawing tools by turning on its icon
button on the Symbol Editor toolbar (illustrated above) or by
selecting the tool from the Add menu. Each tool has a separate
Controls window that opens when you activate the tool and
closes automatically when you switch tools. You can draw elements in the canvas using the mouse or use the tool’s Controls
window to enter precise local coordinates and dimensions.
When you have finished drawing the element, check that you
have selected the desired color and fill setting, then press the
Apply pushbutton on the Controls window or right-click in the
drawing canvas to add the element.

PolyLine and Polygon:
When you select either of these
tools, the Line/Polygon Edit
Controls window opens. Use
these controls to add vertices
to the end or start of the
polyline or polygon or to insert,
reposition, or delete vertices.
Text: When you select the Text
tool, the Text Label Edit Controls window opens (see illustration on the next page). Enter
the text for the symbol in the Text tabbed panel of this window.
The text tool graphic then appears in the symbol canvas. Drag
the baseline of the text graphic to reposition the text. Drag the
size handle of the text graphic (“+” symbol) to change the size
of the text, or enter a value in the Ascender Height field on the
Style tabbed panel of the Text Label Edit Controls. Drag the
(continued)
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Use the Text tool to add
a text string to the
symbol. Enter the text in
the Text tabbed panel of
the Text Label Edit
Controls. Move the text
in the canvas by dragging the baseline, and
resize it by dragging the
size handle. Rotate the
label by dragging either
endpoint of the baseline.

size handle

baseline

node on either end of the text baseline to rotate the text; you
can also enter an angle value in the Baseline Angle field on the
Text tabbed panel.

Outlining Shapes in a Different Color
A filled closed-shape element uses the same assigned color for
its outline and its fill. However, it is easy to create a composite
symbol with a filled shape that is outlined in a different color.
When you add an element to the symbol, the tool graphic remains active in the same location in the drawing canvas. Thus
after adding a filled element, you can simply turn off the Fill
toggle, change the element color to a contrasting outline color,
set an appropriate thickness, and add the new element, which
appears to outline the underlying filled shape.
Symbol consisting of two overlaid circles with
the same position and size: a filled yellow
circle with a black unfilled circle overlying it.

Setting the Symbol Origin
The symbol origin determines how the symbol is positioned
relative to a point element it represents in the display of a geometric object. It is the symbol location (“hotspot”) that is
positioned exactly at the point element coordinates. For new
symbols the origin coincides with the center of the drawing
canvas (symbol coordinate origin). You can use the Origin tool
to indicate a different symbol origin position, such as at the
base of a flag symbol as illustrated. (Doing so offsets the
“hotspot” from the symbol coordinate origin; it does not
change the symbol element coordinates.)
The Origin tool provides a stanorigin set at
dard point tool graphic that you
symbol base
can drag to reposition the origin. Right-click in the canvas
or press the Apply pushbutton
in the Point Edit Controls to accept the new position. There is
no visible indication of the symbol origin position when the
Origin tool is not active.

Element Order and Selecting Elements
Activate the Select tool on the Symbol Editor toolbar to select
a symbol element to change its color, its drawing order, or to
edit it. Left-click on or close to an element to select it. A se-

lected element is highlighted in red (solid for lines, outlines of
unfilled shapes, and text; stippled for fills).
selected
unfilled
shape
selected
filled shape
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Overlapping elements in a symbol are drawn in order from
bottom to top. You can change the drawing order one element
at a time by selecting the element and pressing the Raise icon
button on the toolbar to raise the element one level in the drawing order, or the Lower icon button to move it down one level.
These options are also available from the Edit menu, which
also provides the options To Top (moves the element to the top
of the drawing order) and To Bottom.

Undo and Undo All
You can cancel the last change you made to the symbol by pressing the Undo icon button or choosing the Undo option from the
Edit menu. The text of this menu entry varies to indicate the
nature of the last change (e.g., Undo Change Color, Undo Add,
or Undo Edit). You can use the Undo action to step back through
multiple changes in the symbol.
Select the Undo All option from the Edit menu to remove all
changes you have made to the symbol. If you are editing an
existing symbol, choosing Undo All restores the symbol to the
way it looked when you opened it in the Symbol Editor. If you
are creating a new symbol, Undo All removes all elements you
have added and returns to a blank drawing canvas.

Editing and Deleting Elements
You can edit any element in a symbol by selecting it and choosing the Edit option from the Edit menu. This action activates
the tool graphic in the drawing canvas and opens the Edit Controls for the type of element you have selected, allowing you to
change its shape and geometry. Press the Apply pushbutton or
right-click in the drawing canvas to apply the changes to the
element.
(continued)
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Scale and Scale All

elements to the clipboard. Selecting either option activates the
Paste icon button on the toolbar and the Paste option on the
Edit menu.

You can use the Scale option on the Edit menu to change the
size of the selected element. When you select this option a
Prompt window opens with a numeric field to set the desired
scale (size) relative to the original element size (scale = 1.0).
The default value of 0.5 reduces the linear dimensions of the
element to half of the original size. A
scale value of 2.0 makes the linear dimensions of the element twice as large
as the original size.

You can paste elements from the clipboard into the same symbol or into a different symbol you open (new or existing). These
options allow you to transfer elements from one symbol to another. When you paste, an elastic box initially appears in the
canvas and the Box Edit Controls window opens. You can move
the box to reposition the element(s) and resize the box to change
their size. When you are satisfied with the placement, press the
Apply button on the Controls window or right-click in the canvas to complete the paste operation.

The Scale All option is always active on the Edit menu and can
be used to change the size of all elements in the symbol, using
the same Prompt window as the Scale option.

Open or Paste TrueType Symbol

To delete a selected element, press the Delete icon button on
the toolbar or choose Edit / Delete.

Spline
The Spline option is available on the
original
Edit menu when a polyline or polygon
element is selected. It creates a
smoothly curving line that is a best fit
after spline
to the original set of vertices, and thus
can be used to smooth an initially jagged polyline.

Duplicate and Array
The Duplicate option on the Edit menu creates a duplicate of
the selected element. The duplicate appears over the original
in the canvas and the corresponding tool Controls window
opens, allowing you to reposition or edit the duplicate.
The Array option on the Edit menu allows you to make multiple replicates of the selected element and distribute them in a
regular x-y array. When you select this option, the Array controls window opens. This window provides fields for setting
the number of rows and columns in the array. The X Offset and
Y Offset fields set the distance each replicate is offset from the
adjacent position in the array; the default values are the width
and height of the selected element, so you should increase these
values if you wish to separate the replicated elements. Only
positive offset values are applied, so the the base element is
replicated to the right and upward in the canvas.

You can use characters (glyphs) from any TrueType font to create a symbol or add to a symbol. Use the Open TrueType Symbol
option on the Pattern menu to create a new symbol using the
TrueType glyph or the Pattern / Paste TrueType Symbol option
to paste the glyph into an existing symbol you are editing. When
you select either option, the
Select TrueType Symbol window opens. Press the Font
button on this window to
choose any installed TrueType
font; the name of the selected
font is shown in the adjacent
text field. The glyphs in the
font are shown in an array of
squares in the scrolling list.
Left-click on the desired glyph
and press OK to select it.
When you use Open TrueType Symbol, the glyph is automatically scaled to fit in the visible portion of drawing canvas. When
you paste a TrueType glyph, an elastic box appears in the canvas and the Box Edit Controls window
opens, so you can reposition and resize
the glyph as you would for any pasted element. In either case the glyph is
converted to one or more symbol elements
(one for each closed shape) which can be
selected in order to assign color and TrueType numeral
glyph pasted into
fill, or for editing.
a symbol.

Save as Text / Load from Text
You can easily transfer symbols from one style object to
another in the form of text descriptions. Use the Pattern /
Save as Text option to create a file with the “.sym” file extension and the Pattern / Load from Text option to load the
symbol in the Symbol Editor from the text file.

Save as Query
You can convert a symbol to a style script that you can use
with the Style: By Script option for displaying points in other
geometric objects. To do so, choose Pattern / Save as text
Rectangle element replicated in a 3 x 3 grid using the Array option.
file (*.qry). You can open the style script in the Script Editor to
Copy and Paste
changes settings such as drawing color and scale. However,
The Edit menu includes a Copy option (copies the selected elyou cannot reopen a style script in the Symbol Editor to conement to the clipboard) and a Copy All option (copies all
vert it to a standard symbol.
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