New Features in TNTgis 2020

  Download TNTgis 2020

  Updated 30 Jan 2020

dvd

General System Changes

  • Use of file-based locking on network / shared drives is now optional. The default will be to use OS-based locking in all cases (previously was for local drives only). In some rare cases with older network drives or servers in a multi-user environment, file-based locking may still be appropriate. This can be controlled via the System Preferences window on the Project File tab.
  • Speed up loading of saved settings in various processes. This is particularly noticeable when working with database tables having thousands of fields.
  • Add support for MacOS Catalina.

Image Grid Alignment and Extents Controls

  • A common set of controls has been introduced to processes that typically create raster gridded output from non-raster input. Currently this applies to the Geoformula, Surface Modeling, and Point Statistics Raster processes.
  • The primary change with these controls is to allow precise control over how the output raster cells align to the reference map grid. This involves specifying whether the corner or center of the cell is used, and whether alignment is to the origin (0,0) or based on the data extents. How the output raster is oriented relative to Map or Geographic North can also be controlled.

Display

  • Add a shift-RMB menu for layers in the Display Manager and Legend to provide quick access to selected operations. These include Zoom to (Extents, Maximum, Minimum, Active, Selected), Unmark All, and Remove Layer. These choices will only appear when relevant.
  • When saving a Group or Layout, the selection of which elements are marked / highlighted is retained.
  • Bing Maps - All TNTgis Pro licenses that are authorized for version 2020 will continue to have access to the Microsoft Bing Maps layers during 2020. This includes earlier versions of TNTgis once version 2020 is installed and activated.

Assemble Geomashup

  • There are now Layout and Advanced tabs, which replace the Options and Layout tabs in previous versions. Most settings are grouped on the Layout tab.
  • The user publishing the mashup can now set the width of the sidebar in the generated web page. An optional map background color can also be set for cases where the base map has a non-rectangular extent.
  • All repositionable controls now have the ability to choose any supported location within the map or sidebar for each control. This applies to the Google Maps API only, and also note that some controls such as the Google logo itself cannot be repositioned. Improvements have also been made to alignment of built-in and custom buttons within the map.
  • There is now an option to have a pull-out menu for the Base Map selection. This menu can be positioned on the right edge of the map area to cover less of the map, particularly when there are many base map choices.
  • A custom image/text control can be placed within the map area. This can be used for a logo and/or copyright text and allows both an optional HoverTip for more details and a link to a URL when clicked on.
  • All base layers may now be reordered, including built-in Google layers. Items in the list will now appear in the same order as in the web page menu / control.
  • Allow entering Attribution / Copyright text without first expanding a layer. This copyright text will be displayed in the map above the Terms of Use, scalebar, and any Google copyright message.
  • Added a general "Preview" button that will open the generated page in the user's current default web browser.
  • Add ability to have blank / empty base map, which will render as transparent and use the map background color if any.
  • All text displayed to the end user in the resulting generated web page is contained in a single "textui.js" file. This allows localization of the published map into any number of languages with automatic selection based on the web browser language setting.

     Geomashup - Legend

  • The legend row for a feature or group will be dimmed if a feature is not visible. This includes if the checkmark is off, if the containing group is hidden, etc. For example, it will dim child row if any parent folder is hidden and dim parent folder row if any child is hidden. In addition, when hovering over the name in legend a comment in red is shown giving the reason the feature is not visible.
  • Added method to toggle all children off/on via checkmark icon to the right of the group folder row.
  • A Layer Menu icon is shown to the right of the layer name. Menu has options to show and hide all features and to open and close all folders.

     Geomashup - Search

  • The ability to search features by exported attributes is now available. The attributes are specified when the overlay data is exported and are stored in .search file or .tsd file (xml format).
  • Three search methods are available to apply search rule(s). A rule is composed of the field to search, a rule operator (LIKE, NOT LIKE), and the text to search for. For example, the rule: roads LIKE "highway" searches a field name ‘roads‘ for the word ‘highway‘.
    • 1. Sidebar search field - provides a quick and easy way to search all available fields for the text entered. Simply enter text and press enter. User can further reduce the found features shown by entering sequential searches without clearing the search results. The user should clear the search results to start a fresh search. Note, this is equivalent to LIKE and AND searches using method 2 below. (I.e. if you enter highway in the field, it is equivalent to the by rule method: ALL LIKE "highway", where ALL means to search all fields.)
    • 2. Search Window, by Rule - open the Search Window to access additional controls when running sequential searches. Use the Operator options to set the rule operator (LIKE or NOT LIKE) and the between rule operator (AND or OR). Enter the search term in the field and click submit or press enter. Note, this is exactly the same as method 1 above except it lets the user use the NOT LIKE and OR or options.
    • 3. Search Window, by Query - this advanced method gives the user a way to manually write a complete search query containing multiple rules. The user must enter a complete expression in the proper format.
  • Multiple words can be entered in search field and the search is performed on the entire string.
  • Supports switching between layers. The user can change the active layer and corresponding information from any previous search done for it will show in the sidebar Search Control and the Search window.
  • Search 'fields' are set up for features based on the ValueType in the .search file created via Export Geometric Tileset. If no .search file is available, the .tsd fields will be used (label, description, HoverTip attributes that are used for the sidebar legend).
  • If fields are taken from the legend (.tsd) it lets you rename them. Includes hover tip so user can know if search fields or legend fields are being used. These legend field names are only relevant when a .search file is not available. Default names are ALL (search all fields), Feature Name, and Hover / Brief Text.
  • The map automatically zooms to the found features. Features that don't match the search criteria are hidden in both the map and sidebar legend. If no results are found map features are not hidden.
  • The layer menu (Legend Control) is updated to show only found features.
  • The Search Control in the sidebar is updated to show the number of features found for all layers (x / xxx features found). It will show 'Selected layer is not searchable' message when user selects a layer that is not supported (i.e. non SVG layer)
  • A Search Window is available via an icon in the sidebar Search Control area. This window contains additional search options as well as search and search result information. Use 'Search by' options to switch between By Rule and By Query modes. You can drag the Search window, adjust its size, or close it at any time without changing the current results. Previous search rules for currently shown features are also shown.
  • Shows feedback (feature name and snippet) in the Search Window so user can see attributes that are found for a given feature. After searching, it will list the feature name (as shown in the legend row), the field name, and a snippet of the field value of the found features. Found text using LIKE is shown in red while NOT LIKE features are shown in blue text. (Note, only the first attribute found is shown for AND searches.)
  • Controls are available to clear search results for only the current layer or all layers.

Image Classification

  • The "Edit Training Data" mode is now activated automatically when using Add Class or Remove Class. Any edits will be made to the raster previously opened, if any. When a new class is added it will be selected automatically.
  • Automatically highlight item in class list based on cursor position in view window.
  • Automatically switch dendrogram when change mode between Training and Results. Dendrogram window title will also show whether it applies to Results or Training.

Import / Export

  • When setting default datum transformations for imported data, will no longer default to a transformation that does not have its optional supplemental grid file installed.
  • Export shapefile - Set width of exported database fields based on actual value range. This both reduces the size of the exported file and allows subsequent import or use of the data to avoid converting some integer data to floating-point.
  • Export MapInfo - Limit to single element type (point, line or polygon) to match what format allows.
  • Export BMP - Add options to specify Additional Georeference files to export.
  • JPEG - Handle files with invalid GPS Altitude of 0/0.
  • Export Geometric Tileset - Option to set the Search Table and create .search file.

Geoformula

  • The Script tab now has a section at the top where all "formula" variables are listed. The user can tap/click on a variable to insert into the script at the current cursor location. A ToolTip will be shown with a description of the variable, and for some, the recommended usage.
  • Note that these are sorted into specific groups based on recommended / necessary usage. Output variables are first, then input: [objectname]_Value variables with adjusted values, [objectname] variables with raw image cell values, and [objectname]_X, [objectname]_Y variables with attribute field values. This sorting may not be obvious if only one or a few inputs are selected.

Scripting / SML

  • In ZIPFILE class specify that stored file names are UTF8 to handle non-ASCII names.

Compute Distance Raster from Raster

  • The "Distance Raster" process from prior TNTmips versions has been separated into two processes, Distance Raster from Geometric and Distance Raster from Raster, both on the Image / Spatial Analysis submenu.
  • This new Distance Raster from Raster process computes both "distance" and "direction" to the nearest specified cell values in another raster. Multiple input rasters of any type can now be selected, and the user can choose which cell value(s) to compute the distance/direction to, as well as selecting nearest null or non-null cells.
  • The output distance unit can be in "cells" or any linear unit. The "orientation" of the direction raster can be set to designate whether 0 degrees is at the top/north or right/east and whether values increase in a clockwise or counter-clockwise direction.
  • Color palettes can be automatically generated for the output rasters. Because the direction is cyclic (from 0 to 360 degrees), a "cyclic" palette is set by default, though the user can choose any desired palette.

Image Operations

  • Arithmetic and Indices - The Auto-Scale operation now allows the user to specify the desired output range. The range of each input raster's values will be scaled to the output range specified by the user.
  • Spatial Filtering - Add Laplacian of Gaussian (LoG) filter with arbitrary (odd) dimensions and user-specified standard deviation. The LoG filter is used for edge detection and combines a Laplacian filter with Gaussian smoothing in one pass to reduce the effects of noise.
  • Reassign Cell Values - Add option to output binary raster.
  • Rig Camera Alignment - Support MicaSense Altum multispectral and MicaSense RedEdge-MX (10 band) cameras. Support Agrowing 4 lens (12 band) with Sony Alpha 7R model 2 (41 megapixel) and Sony Alpha 7R model 4 (61 megapixel) cameras.
  • Hyperspectral Analysis - When open additional image views the Geolock setting is now available to keep the views showing the same area as the main view if desired.

Geometric Operations

  • In Directional Analysis allow user to control whether lines are considered to be bidirectional or not for generating the Rose Diagram.
  • Redesign Voronoi Region process to support larger datasets.
  • Vector Filters - The line Simplification and Densification filters will now report to the log when lines are not able to be processed along with an explanation of possible reasons for this (typically due to intersecting other lines) and the list of lines that were not processed. This can be helpful in adjusting parameters or manually adjusting the affected lines.

Geometric Point Statistics Raster

  • This redesigned process replaces the Point Density Raster process. This process now allows any geometric object (vector, CAD, shape) as input. Job processing is also now available.
  • In addition to computing "density" based on points within a specified radius, statistics based on point counts can be computed per raster cell, and both total and points per cell or unit area can be output.
  • Many new statistics can be computed based on attribute fields associated with the points. These include Sum, Mean, Minimum, Maximum, Range, Variance, and Standard Deviation. Any number of attribute fields may be selected.
  • Now uses the new output grid controls as described above.
  • Each output raster can have a color palette automatically generated based on the range of values in that raster. If no palette is desired, the Color Spread can be set to None.
  • The output raster cell type is now automatically determined based on settings and input values.

Raster (DEM) Topographic Properties

  • Allow multiple input objects.
  • The interface for this process has been rearranged to clarify grouping of options for each property and accommodate newly added ones. For most properties, the output raster cell type will be automatically determined based on the input DEM cell type and whether floating-point values are needed.
  • Include user-settable parameters in the default output name and descriptions. When multiple input objects are used the output names will also be based on the input object names.
  • For Shading add a choice of "Incidence Angle Cosine" to match the shading compensation used in the Radiometric Correction process.
  • For Profile Curvature add control of whether positive values indicate the surface is upwardly convex or concave (and the opposite for downward).
  • Add Laplacian of Gaussian with user-specified standard deviation. This property provides another measure of surface curvature in a local neighborhood.
  • Add Topographic Position Index (TPI). TPI compares the elevation of each cell in a DEM to the mean elevation of a specified neighborhood around that cell. Positive TPI values represent locations that are higher than the average of their surroundings, as defined by the neighborhood (ridges). Negative TPI values represent locations that are lower than their surroundings (valleys). TPI values near zero are either flat areas (where the slope is near zero) or areas of constant slope (where the slope of the point is significantly greater than zero).
  • Add Slope Position classification based on TPI. This property classifies cells into Ridge, Upper Slope, Middle Slope, Lower Slope, Valley, and Flat classes. The user has the option to choose the colors used in the classification. For more information on TPI and SP classification see www.jennessent.com/downloads/tpi-poster-tnc_18x22.pdf.
  • Add Terrain Ruggedness Index (TRI) and Roughness. TRI is defined as the mean difference between a central pixel and its surrounding cells. Roughness is computed as the largest inter-cell difference of a central pixel and its surrounding cell. See Wilson et al 2007, Marine Geodesy 30:3-35.
  • Compute Positive and Negative Openness rasters. Openness expresses the degree of dominance or enclosure of a location on an irregular surface. See Ryuzo Yokoyama, Michio Shirasawa, and Richard J. Pike, Photogrammetric Engineering & Remote Sensing, March 2002.
  • Save color palette with Aspect output. Because the aspect output is "cyclic", varying from 0-359, the default palette will be cyclic. The user has the option to pick any palette, but there is a message that says a cyclic one is recommended for best results, with option to not show the message again.
  • In the Sun Angle Calculator the user can now specify the UTC offset to the local time zone. All currently-used timezone offsets are avialable for selection.

TIN Merge

  • Allow merging of any number of TIN objects in a single operation.
  • Add Job support.

Lidar / Point Clouds

  • In Lidar Classifier handle scaling for non-Lidar small-area point cloud data such as from macrophotography.
  • In Lidar Manager automatically set precision for Area Extents fields based on maximum from input to better support small-area high-precision point clouds.
  • Automatically set CRS as "Local" if input files have Local CRS.

Coordinate Reference / Datum Transformations

  • Add Bavarian NTv2-Datei BY-KanU grid transformation.
  • Add GDA2020 / MGA2020 datum and CRS zones for Australia.

Miscellaneous

  • In Color Palette Editor add new CET Uniform Perceptual color palettes (2 diverging, 6 linear, and 10 "color-blind").
  • Change Text File Encoding - Allow multiple files to be processed and add controls for both input and output encodings to clarify usage.
  • Surface Modeling - Uses new Grid Alignment Controls described above to allow selection of any geospatial object to designate extents and grid alignment.
  • Various - When operations occasionally produce an all-null output raster, the error message will now show the corresponding file and object names. This will aid in determining which input is causing the problem when multiple input objects are involved.

Contact Support Window

  • Allow upload of support requests via web browser to enable connection when firewall is in use or from a different device.
  • Add Windows diagnostic report to aid in analyzing complex issues.
  • Optionally include Mac crash log(s) for diagnosis.
  • Now run as a separate process to allow use of other menu options while Contact Support window is open or uploading.