dvd

New Features in TNTgis 2015

  Download TNTgis 2015

  pdf Highlights Only

Highlight Features

  • Run TNTgis software in Mac OS X 10.10 Yosemite.
  • Compute Rational Polynomial (RPC) model for orthorectificationn in the Georeference process from image 3D control points.
  • The Auto-Register operation in Georeference automatically assigns Z values for new 3D control points from a DEM using the Default Z from Surface option.
  • Faster RPC orthorectification in the Image Resample process using the Image Processing Pipeline.
  • New multi-band raster image layer allows RGB display using any set of three bands from the image; the display band choice can be changed at any time in the Layer Controls.
  • Mosaic grayscale, RGB, or multi-band images with contrast matching to an input image or separate reference image.
  • The Raster Calculation process includes a new Vegetation Indices category allowing computation of of many broadband vegetation indices from multi-band images.
  • The Geometric Buffer Zone process provides many new features including options to merge buffer polygons, the option to buffer vector nodes, and new polygon buffer options: Expand, Shrink, Outer Ring, Inner Ring, and Border.
  • The Database Table Properties window has been redesigned for easier use.

Processes redesigned with added capabilities:

  • Image Spatial Filtering, Raster Calculation, Buffer Zone Generation.
  • Image Statistics by Geometric Element, Image Statistics by Category Raster.
  • Surface Properties by Geometric Element, Geometric Element Statistics, Polygon Shape Properties.

Full Feature List

    System

    • Run TNTgis software in Mac OS X 10.10 Yosemite.
    • Allow user to specify interface language during first use.
    • When user changes language, a message encourages adding interface fonts to provide required characters.
    • Enlarge Controls option in General System Preferences for use with small touch screen tablets.
    • Access License Configuration window via the TNTmips Help menu or Tools / System menu.
    • Add '2D vector to 3D vector' process to Terrain menu.

    File/Object Selection Window

    • Typing text auto-scrolls to first matching item in list.
    • Time included with date in Created and Modified columns.
    • Assigns auto-name default when click in field to manually assign name.

    Job Manager

    • Schedule window redesigned to provide more intuitive controls. TechGuide
    • Schedule window provides option to perform the job once at a particular date and time in addition to repeat scheduling.

    File Manager

    • Object information for linked tables shows link info: server name, IP address, and database.

    Project File Recovery

    • Added option to save the original file with a backup name and use the original name for the output.
    • Provides a default output file name.

    Color Palette Editor

    • Added ability to import a color palette from a text or CSV file.
    • Added "Uniform Perceptual Contrast" palettes provided by the Centre for Exploration Targeting in Australia.
    • When a standard palette is selected to save with a spatial object, the palette name is offered as the default color map subobject name.
    • Palette selection window shows preview of each palette.
    • Added palettes for USGS recommended geologic map colors.

    Spatial Display

    View Window

    • Set sidebar to be on either left or right side of View window (Options / View Options from Display Manager).

    Layer Info Window

    • Layer Info Window (formerly View Extents) redesigned with expandable sections showing layer info and extents, coordinate reference system, object information, and georeference details. TechGuide
    • Cell size is shown in arcsec for rasters with geographic georeferencing.
    • Row and column labels added for raster dimensions and cell size.

    Raster Layer

    • Allow RGB display of rasters with different cell sizes and extents. TechGuide
    • New multi-band raster image layer allows RGB display using any set of three bands and changing display choice at any time. TechGuide
    • Use Add Objects to select any number of image bands for display with choice of adding as separate layers, as RGB layer, or as multi-band layer. TechGuide
    • Explicitly add multiband image layer from Add Raster menu.
    • (multi-band)" is automatically appended to the default layer name for multi-band layers.
    • Options setting provided for adding named Red, Green, and Blue objects automatically as RGB layer from Add button.

    Vector Layer

    • Optionally show line/polygon vertex locations and choose symbol.
    • Line vertices are not shown in the Locator.
    • Option to hide nodes in the Locator.

    Mark by Attribute

    • Add option to mark elements that share records in the table specified.

    GeoFormula Layer

    • DataTips are now available for GeoFormula layers.
    • Option to apply auto-contrast to the output display for RGB and numeric GeoFormulas.
    • Option to apply color spread of your choice to the output display for numeric GeoFormulas.
    • GeoFormula Layer Controls window redesigned, uses icon buttons for script actions.

    Web Tileset Layer

    • Copyright is shown as part of the DataTip in the View and in the Object Selection window.
    • The Tileset Layer Controls window includes a Terms of Use button.
    • Web tilesets accessed through an HTTPS URL are supported.

    Dynamic Labels

    • Trailing 0s are automatically stripped from decimal values.

    Annotate Tool

    • Added choice of color palettes on color-selection control.

    GeoToolbox

    • Save a region as a vector object from the GeoToolbox Region panel.
    • A Hide Crosshairs option has been added to the Show menu in the Profile View.

    KML Layer

    • Option on Layer Controls to override label styles embedded in the KML file.

    DataTips

    • Set DataTip Options for 3D Views via the View window's Options menu.

    Printing

    • A warning message is shown if print size is changed to be different than set for the layout.

    Render to

    • KML: Choice to exclude elements from output if they don't have a DataTip attribute set.
    • KML: NAME and DESCRIPTION tags restricted to elements with DataTip set.
    • KML: Option to render 3D extruded elements.
    • SVG: NAME and DESCRIPTION tags restricted to elements with DataTip set.
    • PDF: Provide option to not render hidden layers.
    • PDF: Include background color when rendering a display layout.

    ToolScripts and MacroScripts

    • Method provided for a display script to prevent showing error messages while drawing layers.

    Database Tables / Operations

    • DataTip shows full-precision value for floating point fields set to display fewer decimal places.
    • Edit computed field expression from tables using right-mouse button menu on the field name.
    • Sequential values created automatically in new Auto-Increment field for all existing records.

    Single Record View

    • Fields in new record initially show default values or are blank.
    • Field labels apply to single-record views in addition to tabular views.

    Tabular View

    • Right mouse-button option on field to select all records that have same value.
    • Field menu options to move column all the way to the left or right.
    • With one record per element attachment, only show warning about changing record attachment once per session.
    • Create and attach new records with or without the option to populate fields. TechGuide
    • Show field name and description as tooltip over column heading.
    • Allow sorting on multiple fields with mixed ascending and descending order.
    • Create new record using Record / New menu option or using New Record icon button.

    Database Table Properties Window

    • Table Properties window redesigned for easier use.
    • Create auto-increment numeric fields.
    • Set default value for logical and string fields in addition to numeric fields.
    • Computed" and "String Expression" fields are now termed "Computed Numeric" and "Computed Text".
    • Set Text and Numeric field properties (e.g., integer type, floating point) first with option to set as Computed.
    • Choose "Simple Computed" field type for field that returns value of a field in another table.
    • Set size of text fields (maximum number of characters allowed).
    • Allow changing field type among compatible types (32-bit integer, date, and auto-increment) for existing fields.
    • Unit type automatically set to "Date" when create Date field.

    GeoTagged Image Database Creation

    • Allow opening the Display Manager from the Database Pinmap View window.

    Editor

    • Line/Polygon tool: ability to extend line by distance and bearing in manual mode.
    • Snap operation: added preview option to step through the gaps with choice to snap or skip. TechGuide
    • Snap operation: arc-wedge graphic shows and allows control of snap distance/snap-back angle.
    • Snap operation: ability to mark dangling nodes when preview snap.
    • Added option to Remove Excess Nodes operation to Ignore Z Values for 3D vector.
    • A line being edited is allowed to cross another line.
    • A line being edited can be snapped to another element.
    • When snapping to another element while adding or editing a line, the prospective snap point is indicated by an X symbol.
    • The Automatic line editing mode switches to Add Start if the end node is out of the View window extents.
    • In Automatic line editing, use "/" hotkey to switch between Add End and Add Start.
    • The Line tool start or end node is highlighted in color in Add Start and Add End modes.
    • The Line/Polygon tool now has additional icons for Stretch mode with different angle constraint settings (Stretch, Stretch + Constrain Angle, Stretch + Constrain Angle to Last Segment).

    Georeferencing

    • Compute Rational Polynomial (RPC) model for orthorectification from image 3D control points. TechGuide
    • Auto-Register operation automatically assigns Z values for new points from DEM when the Default Z from Surface option is set.
    • Default coordinate reference system set from reference image.
    • Use Model button to open Select Model dialog with listing and description of all coordinate transformation models.
    • Supports RPC coefficient file format for KOMPsat-2 images.

    Geometric Object Operations

    Buffer Zone Generation

    • Buffer Zone Generation window redesigned to show all process parameters on one panel.
    • Use icon buttons to select the available input element type(s) to buffer and (for polygons) the type of buffer to produce. TechGuide
    • New polygon buffer options: Expand, Shrink, Outer Ring (Expand - Original), Inner Ring (Original - Shrink), and Border (Outer Ring + Inner Ring). TechGuide
    • Option to buffer vector nodes, including By Attribute and By Script.
    • Options to merge buffer polygons (all or by attribute).
    • Merging buffers is mandatory when output is a region object.
    • Option to assign buffer distance by attribute. TechGuide
    • Set Multiple Equal Distance buffers by specifying start distance, interval (buffer width), and number of buffers. TechGuide
    • An attribute is automatically assigned to indicate if an output polygon is part of a buffer area.
    • For single buffers the buffer distance is automatically included in the default output object name and description.
    • A Buffer table with buffer distance record is created for single-distance buffer output (in addition to multiple distance output).
    • A "Keep saved result" preference setting allows keeping or saving previous results in View.

    Geometric Extract

    • Allows setting up extraction by attribute one time for all inputs. TechGuide
    • Optionally save the manually drawn extraction area as region. TechGuide
    • When select the Region option in Define Region window, the sidebar Region Manager is automatically activated.

    Geometric Filters

    • Add Layer icon button added to View window.

    Geometric Element Statistics by Polygon (formerly Polygon Properties)

    • Process renamed and window redesigned. TechGuide
    • Use any geometric object type as source (vector, CAD, shape).
    • Use database pinmap as source of points.
    • Find statistics for source lines (as well as polygons and points).
    • Optionally create the output tables for a copy of the "Destination" vector/CAD object or as CSV text file.
    • Summarize statistics for any numeric field and table with any record attachment type.
    • When summarize "by attribute", create either fields in one record or separate records for each attribute.
    • Option to choose field to provide element name/ID in each table record.

    Polygon Shape Properties (formerly Fuzzy Properties) TechGuide

    • Process window redesigned, providing a choice of statistics to compute and new shape measures.
    • Compute shape properties for elements in CAD and shape objects in addition to vector objects.
    • Optionally create the output table as CSV text file.
    • Object in geographic coordinates is converted to orthographic projection centered on object when properties are computed.
    • Option to choose field to provide element name/ID in each table record.
    • Add Reock compactness/circularity measure.
    • Add Convex Hull compactness measure.

    Image Statistics and Surface Properties by Geometric Element

    Image Statistics by Geometric Element (formerly Geometric Raster Properties) TechGuide

    • Process window redesigned, providing new statistics and a choice of which to compute.
    • Option to compute texture Gray Level Co-occurrence statistics by polyon.
    • Choice of element type to use, now including lines in addition to polygons and points.
    • Options to output results in tables in input object, to a copy of the input object, or to CSV text file.
    • When using multiple rasters, statistics tables are automatically named using the raster name.
    • Option to put statistics of multiple rasters into one table.
    • Compute raster properties for elements in CAD and shape objects in addition to vector objects.
    • Option to summarize statistics "by attribute" to create a separate record for each attribute.
    • Compute statistics for all elements of the selected type or only those marked in the View.
    • Compute statistics from bands in hyperspectral object.
    • Option to choose field to provide element name/ID in each table record.
    • Option to use TNTmips Job Processing.

    Surface Properties by Geometric Element TechGuide

    • Process window redesigned, providing new statistics and a choice of which to compute.
    • Compute surface properties for elements in CAD and shape objects in addition to vector objects.
    • Optionally create the output tables for a copy of the "Destination" vector/CAD object or as CSV text file.
    • Option to choose field to provide element name/ID in each table record.
    • Option to use TNTmips Job Processing.
    • Compute measures of surface roughness: 3D/2D area ratio, elevation standard deviation.
    • Added "All" option for quickly choosing all surface statistics.

    Image and Raster Operations

    Image Extraction

    • Range and Manual extraction modes have mutually-exclusive tool sets for clearer operation (use Select menu to switch).
    • Region form added to Manual method.

    Feature Mapping

    • Date format in reports set automatically to format used to enter the processing date.

    Mosaic

    • Match contrast to any reference image (doesn't need to be part of the mosaic).
    • Specify contrast option for source image set as reference for contrast matching. TechGuide
    • Contrast-match grayscale, RGB, and multi-band images.
    • Apply previously-saved contrast or auto-contrast to input images during mosaic assembly.
    • Apply contrast after mosaic assembly.
    • Linear contrast table is automatically created for the mosaic when contrast is applied.
    • Mosaic RGB separates to either RGB composite or RGB separates. TechGuide
    • Set user-defined extents in View using Output Extents rectangle tool. TechGuide
    • Apply scale and offset when different for various input rasters (such as DEMs in different elevation units).
    • Progress percentage value shown as part of progress bar in status field.
    • When mosaic to tileset the total number of tiles created is shown in status and in log.
    • Select RGB bands for multiband source images via toolbar icon button or Parameters panel pushbutton.
    • Access provided to Layer Controls for styling "Output Region" layer outline.

    Morphological Operations

    • Preview window is non-modal.
    • View-in-View tool added to Preview window.

    Progressive Transformation

    • Control window redesigned to include feature statistics and an arrow icon button to step through creation of the transformation components.
    • Open the Image Band Correlation window from the Progressive Transformation window.
    • Process rasters of all numeric data types.
    • View displays a color-composite from your choice of three input bands.
    • DataTips shown in View for all layers by default.

    Raster Calculation

    • Added Vegetation Indices category with many broadband indices. TechGuide
    • Allow 16-bit signed/unsigned output for "indices" group. TechGuide

    Raster Combination Statistics

    • Raster combination statistics moved from Raster Calculation to separate process (Image / Combine / Statistics).

    Raster Contrast Matching

    • Option to copy contrast table from reference also copies display parameters so contrast table is used by default.

    Resample/Reproject

    • Faster RPC orthorectification using Image Processing Pipeline.
    • RPC orthorectification automatically ignores nominal control points provided with ALOS PRISM scenes.
    • File/Object Name for the current image is included in the progress message.
    • Null masks are supported for source and target images when using the RPC model.

    Spatial Filtering

    • Spatial Filter control window updated with easier-to-use controls and resizeable display of filter kernels. TechGuide
    • All filters allow variable blending of source and filter result to create output image.
    • Select from predefined filter window sizes (up to 21 x 21) or edit the size field to set a custom size.
    • Added family of Gray Level Co-occurrence Matrix Texture filters (Contrast, Dissimilarity, Homogeneity, Entropy, and others). TechGuide
    • Added a Gaussian smoothing filter. TechGuide
    • Added a damping factor to the Frost filter for radar images.
    • Import/export a filter kernel from/to a text file.
    • Option to repeat a filter operation a specified number of times.
    • Optionally apply contrast (auto-contrast or saved table) to grayscale or RGB input before filtering.
    • If contrast is not applied, input contrast tables are automatically copied to the filter result.
    • Single View and tool set for restricting filtering to a designated image area for output or for testing. TechGuide
    • Define output or test area by drawing, by selecting a region object, or selecting a binary mask raster object.
    • Region manager control in View sidebar allows saving the specified area as a region object.
    • Indexed-color composite images are automatically filtered by color rather than by arbitrary raster value.
    • Allows adding input rasters to the list without reselecting previous inputs.
    • When filter kernel weights are edited, the filter name automatically switches to "User Defined".
    • Specify the number of decimal places to show for weights in the filter kernel.
    • Input raster list includes image type, cell size, and row-column dimensions for each input raster.

    Statistics by Category Raster TechGuide

    • Process window redesigned, providing new statistics and a choice of which to compute.
    • Optionally create the output table as CSV text file.
    • Option to put statistics of multiple rasters into one table.
    • Select field to provide category name/ID in each record in table.
    • Compute statistics from bands in hyperspectral object.
    • Option to use TNTmips Job Processing.

    Image Thresholding

    • Updated View window includes icon button to open Layer Manager window.

    Terrain Operations

    Extract Points or Mesh

    • Added option to extract regularly-spaced 3D points from input raster.
    • Added option to output as CAD object.
    • Regular mesh created with network topology to speed processing.

    LIDAR Manager

    • Check to ensure there is enough space for output.
    • Provide method to adjust point X, Y, and Z values by fixed amount.

    Import/Export

    • Updated to use GDAL 1.11.
    • Export to AutoCAD 2013-2015 DWG file format.
    • Import and Export Arc Floating Point raster format.
    • GeoTIFF import/link automatically recognizes and ingests an RPC coefficient file and stores the parameters as part of the georeference.
    • 3D geometric coordinates preserved when export to GML.
    • Allow user selection of element types to be exported to GML.
    • Enable export of labels to GML.
    • Export geometric objects to Well Known Text (WKT).
    • Export SVG and KML: NAME and DESCRIPTION tags restricted to elements with DataTip set.
    • Export vector tractor track lines to SHP in Trimble AgGPS Autopilot structure.
    • Import Raster: Added crop and/or sample option for single and multiband image files.
    • Import Raster: crop and/or sample to Basic or Free license limits.
    • Import Raster: crop/sample interface detects separate input image files with same dimensions and treats as one image.
    • Import Raster: when using crop/sample interface, option to specify range by column/line numbers.
    • Allow import of JPEG2000 files with .jpf extension (from Photoshop).
    • Import TEXT-X Y Z to raster: Added Custom (One Cell per Line) option to set import to skip column of input file.
    • Import TEXT-X Y Z to raster: Comma is now the default delimiter.
    • Import ALOS PALSAR level 1.1 data.

    Export Geometric Tileset

    • Create geometric tilesets from CAD or Shape input.
    • Preview HTML options include None and Open Layers in addition to Google Maps.
    • Google Earth Tilesets: Allow specifying Z values for output for 3D extruded elements or as surface.

    Export Terrain Tileset

    • Supports tiled comma-separated text format used by Geospatial Information Authority of Japan (GSI).

    Assemble Geomashup

    • Sidebar search box to find map features by text contained in name or description (Google Maps and Open Layers).
    • Choose shape of legend samples (rectangle or polygon) for geometric tilesets (Google Maps and Open Layers).
    • Provide option to make a layer not clickable, so no info balloons.
    • Sidebar legend element entries sorted alphabetically for KML layers (Google Maps and Open Layers).
    • View zooms and pans to elements selected in sidebar legend (Google Maps and Open Layers).
    • Choose color used to highlight geometric tileset elements selected via legend sample.
    • Option to show KML sidebar legend element entries only if element is in view.
    • When previewing with KML layer, pop up message warning of restrictions on displaying local files.
    • Dim preview button for any browser not installed.
    • Allow selection of Google Fusion Table via table ID.
    • Overview map is set by default to open.
    • Adding image tilesets to an existing group does not open the Group Settings window.
    • Provide choice of Bing Maps base layers (hybrid, roads, aerial) in Open Layers geomashups.

    GeoFormula Object Combinations

    • GeoFormula window redesigned, uses icon buttons for script actions.
    • New option on Output panel to match cell grid to a reference raster without matching extents.
    • Open a preview of the result using the Preview icon button.
    • Input objects can be reselected, added, or removed while editing a GeoFormula.
    • Duplicate output object names are automatically incremented by adding a number at the end.
    • The name of the selected GeoFormula file is shown in the window title bar.
    • All Output Panel settings are saved in the GeoFormula file.
    • Output Panel settings are automatically reset to default values when a new formula is created via the Wizard.
    • Specify text encoding option when saving the GeoFormula file.
    • GeoFormulas can create output rasters with rectangular cells (unequal row and column cell sizes).
    • Open the GeoFormula process from Image / Combine / GeoFormula or Script / GeoFormula.

    Geospatial Scripting

    Script Editor Window

    • Text in SML Editor console window can be selected and copied.
    • Text in Script Reference window can be selected and copied.

    Functions and Classes

    • Ability to add a region layer to a display created by script.
    • Add Write methods to RVC_NULLMASK class.
    • Added function to create a raster by specifying the RVC_OBJITEM of parent (e.g., a folder in an RVC file); (Raster / Create RasterInParent).
    • Added function to compute image statistics by category (Raster / ComputeImageStatsByCategory).
    • Added function to find the closest polygon to the specified polygon (Vector / FindClosestPolyToPoly ).
    • Added method to POLYLINE class to compute distance to a specified POLYLINE (ComputeDistance).
    • Added function to convert Vector object to CAD object (Object Conversion / ConvertVectorToCAD).
    • Added function to merge CAD objects (CAD / CADmerge).
    • Added function to compute raster properties for a CAD object (Raster / ComputeRasterPropertiesCAD).
    • Search method added to STRING class.
    • Improved support for regular expressions used in searching/matching character strings.
    • Class method added to unzip a ZIPFILE.
    • Class method added to specify a datum transformation for a coordinate reference system.
    • Round function now allows rounding a floating point value to the specified number of digits.
    • Added functions to extract surface points or mesh.
    • Added support for image contrast matching.
    • Added methods to STRING class to remove and add quotes around strings.

    Script Reference

    • All classes are organized into categories that can be expanded/contracted in list.
    • Class members (variables) and methods (functions) are listed in separate categories.
    • Class method listings show parameter lists and all variants of the methods.
    • Functions/methods with "index" parameter show whether indexing starts at 0 or 1.

    New Coordinate Reference Systems and Components

    • Support NTv2 datum transformation method using national grid shift files.
    • Added NTv2 datum transformation between OSGB36 (British National Grid) and WGS84/ETRS89.
    • Added NTv2 transformation for Ireland.
    • Added NTv2 transformation for Germany, DHDN to ETRS89/WGS84.
    • Added NTv2 transformations for Australia and New Zealand.
    • Added NTv2 transformations for Spain and Portugal.
    • Added NTv2 transformations for Austria, France, The Netherlands, and Switzerland.
    • Added NTv2 transformations for Canada, Brazil, and Venezuela.
    • Added Democratic Republic of Congo Datum.
    • Added Laos 1997 datum.

    Interface Translation (Localization) Utility

    • Ability to mark entries as not needing translation and to hide these items.
    • Option to check translation for missing string substitution fields.
    • Window provides line numbers for text items.
    • Option to "go to" the specified line number.
    • Option to move to the next empty translation item.
    • Button to copy English text to translation area, including HTML tags for Help sections.
    • Indicator if entry is changed wince the previous version.
    • Options to show only General, Help, or Error items.

    TNTatlas

    • Access Contact Support form from the Help menu.
    • Added ability to open a saved display group.
    • Set TNTatlas X Server preferences separate from TNTmips.

    TNTedit and TNTview

    • Help menu provides options to browse and search documentation as in TNTmips.