dvd

New Features in TNTgis 2014

  Download TNTgis 2014

  pdf Highlights Only

Highlight Features

  • Redesigned and streamlined Mask Editor, Geospatial Catalog Manager, Style Assignment dialog, and Print dialog.
  • Import, create, and edit EPANET pipe network vector objects and run EPANET hydraulic simulations within TNTmips.
  • Vary the transparency of any raster or geometric layer in a view using a slider in the View window sidebar.
  • Use global MapQuest map and image tilesets in addition to Bing Maps as public reference layers in any view.
  • Use active or selected elements for measurement, sketches, regions, and profile generation.
  • View histograms, apply contrast, and match contrast for color-composite images.
  • Support for direct use, import, and export of many new file formats including ESRI File Geodatabase and GeoRSS.
  • Create Open Layers geomashups using geometric web tilesets (SVG and KML) with legends, custom sidebars, and drawing/measurement tools.

Full Feature List

    System

    • Run TNT products in Mac OSX 10.9.
    • Access database operations from the new Database menu on the TNTmips menu bar.
    • Access object conversion operations from Convert submenus on the Image, Geometric, and Database menus.
    • If a main control window in a TNT process (or a modal dialog such as a prompt or message window awaiting input) is hidden behind other windows, pressing ctrl-w makes it active and brings it to the front.
    • Pop-up windows that are automatically positioned relative to their parent (such as layer and group settings) are forced to open entirely on-screen if the parent is near the edge.
    • Open additional 2D views from the layer manager in any process.
    • Localize TNT interface to Myanmar language.
    • Improved descriptions for TNT executables are shown in Windows Task Manager.

    File/Object Selection

    • Select ESRI File Geodatabase folder as if it were a file.
    • A message is shown if the ESRI File Geodatabase selected is not a supported version (pre-10.0).
    • Control added in some contexts to allow selection of a folder or navigating inside it.

    Geospatial Catalog Search

    • Search both local geocatalogs and the MicroImages online webmap catalog when selecting objects for display or other operations.
    • Search for tilesets and KML files.
    • Warning provided if no catalog is found.
    • Object type icon is shown in the search results list.

    Geospatial Catalog Manager

    • Catalog Manager window redesigned to provide easier use.
    • Catalog Manager window can be resized.
    • Catalog Manager icons provide more informative ToolTips.
    • Folders presented in expandable/collapsible tree structure for ease in navigation and selection.
    • Building or updating a catalog is automatically done in the background using TNT Job Processing.

    Spatial Display

    General

    • Use global MapQuest map and image tilesets in addition to Bing Maps as public reference layers in any view. TechGuide
    • Vary the transparency of any raster, geometric, or terrain layer in a view using a slider in the View window sidebar. TechGuide
    • Open an atlas in TNTmips Display and TNTview from its atl file.
    • Choose the tool to be initially active in new views (in Display Manager / Options / View Options, View tab).
    • Auto-Projection options for groups automatically adjust projection parameters for data location and extents (e.g., Auto-Equirectangular method adjusts aspect ratio for data with Latitude/Longitude coordinates).
    • Group Settings provides warning if clipping settings result in no layer in group being visible.
    • Set thresholds for triggering the dense layer visibility prompt based on minimum object size and average element spacing (in Display Manager / Options / View Options, Layer tab).
    • Save metadata with saved groups and layouts.
    • Option to restore default settings to Color Balance window.
    • Export bitmap point symbol patterns to PNG.
    • Layer right-mouse button menu provides option to copy display parameter settings from source object to multiple objects.

    View Window

    • Open Additional View choice added to View menu.
    • Web Layer option added to the Add Layer icon button menu.
    • Hotkeys added to open zoomed-in (>) and zoomed-out (<) views.
    • Hotkey added (*) to open additional view at same scale as current view.
    • Hotkey added (^) to center other views at cursor.
    • Zoom-out hotkeys added for keys 6, 7, 8, and 9.
    • Hotkey added (backspace) to return to previous view extent.
    • Zoomed-in views retain their location and scale when new layers with larger extents are added.
    • The active layer is used if possible when zooming to maximum detail
    • The last-used design scale is set as the default design scale when a new group or layout is created.
    • ToolTip for the Position Report fields shows the coordinate reference system.
    • When selecting a coordinate reference system for the Position Report fields, the coordinate reference system currently in use is shown in the Current field.
    • Quick Snapshot to GeoTIFF format automatically includes georeference information if available.
    • Option to automatically open saved snapshot with the default application associated with the selected file format.
    • Stereo views automatically use the elevation unit set for the terrain layer to adjust stereo displacement.

    View Window Tools

    • Reposition tool icon has been changed.
    • Synchronize External Geoviewer tool icon has been improved.
    • Point Profile shows only points that are selected to draw in the View. TechGuide
    • View Position Tool: double-click to zoom in, double-click to zoom out.
    • View-in-View Tool: View toolbar icon whether the area inside or outside the box is active.
    • View-in-View Tool: layer visibility checkmark color changes to indicate whether the layer is visible in the active View-in-View area.
    • Annotate Tool: option to save sketch to KML.
    • Tool colors can be set in View window from Select Colors dialog (Options / Colors).

    DataTips

    • Set scale range for allowing DataTips for object independent of layer scale range.
    • Set units to show for raster-value DataTips.
    • Set minimum and maximum dimensions for geotagged image thumbnails to be shown in DataTip.
    • DataTip settings are saved with groups/layouts.
    • A new DataTip Settings window accessed from the View window (Options / DataTips / Settings) allows the user to modify DataTip characteristics for the current viewing session: TechGuide
    • Enable/disable mouse-over highlighting of corresponding elements.
    • Set element highlighting as the default behavior for newly-added layers with no previous setting.
    • Include object names with the DataTip.
    • For numeric values, set a thousands separator (comma, period, space, or none).
    • Set a maximum number of lines to show for multi-line DataTips.

    Display Manager and View Sidebar Controls

    • Layer Transparency pane added to sidebar options. TechGuide
    • Display / New submenu includes separate options for creating Display and Tiled layouts.
    • Display Open option allows multiple groups/layouts to be opened.
    • Options menu includes choice to clear the web cache.
    • Open Print dialog from icon button on the toolbar.
    • Customize the Display Manager menus and icon bar using Options / Hidden Features.
    • Dimmed colors are used for names of layers that are not visible due to scale, extent, etc.
    • Select a range of layers to raise/lower, remove, show/hide, or exclude from group extents (shift-left-click or shift-right-click on a layer selects all layers from the active layer to the layer you click on and opens a menu of actions to apply to all of the layers). TechGuide
    • Toggle show/hide for a range of layers (shift-left-click on visibility checkbox toggles visibility for all layers from the active layer to the one you click on). TechGuide
    • Toggle show/hide for a range of layers for specific views (shift-right-click on visibility checkbox selects all layers from the active layer to the one you click on and pops up a menu to select numbered view or Locator). TechGuide
    • Database table lists are sorted alphabetically by table name.
    • DataTip on name of linked database table shows the source database name.
    • Use layer right mouse-button menu to copy display settings to other layers of the same type in view, with option to save.
    • If object has no metadata, layer right mouse-button menu includes an Add Metadata option.
    • Use geometric element right mouse-button menu to show hidden tables.
    • Region creation options are shown (dimmed) on element right mouse-button menu even when no element is marked.
    • Use group or layout right mouse-button menu to save object. TechGuideTechGuide
    • Use group right mouse-button menu to add layers. TechGuide
    • Use group right mouse-button menu to disable/enable DataTips for all layers in group. TechGuide
    • Use group right mouse-button menu to disable/enable element marking for all layers in group. TechGuide
    • Use group right mouse-button menu to apply new Default Layer Name setting to layers in saved group or layout. TechGuide
    • Right mouse-button menus for Scale Bar, Legend, and Text groups provide option to open Group Settings window.
    • ToolTips on names of saved groups and layouts shows the file path and object name.
    • Option to hide all layers in Locator View.

    Geometric Display Layers

    • Display ESRI File GeoDatabase 10.0 files as CAD layers.
    • Display Arc/Info Coverage, E00, and Generate files as CAD layers.
    • Display S57, GML, GPX, CSV (Comma Separated Values) and GeoRSS / GeoXML files, GeoJSON, and others as CAD layers.
    • TIN: set triangle fill options None, Enable for 2D only, or Enable for 2D and 3D.
    • Vector: option to cancel during rendering of large object.
    • Internal Element Details window shows "No Element Selected" message if no element is marked.
    • When displaying dynamic labels and setting label text by script, can use "return" keyword to set the string or string expression to use.

    Styling Geometric Display Layers

    • Expanded library of predefined geometric point symbols.
    • Use any predefined point symbol to style nodes.
    • The default line color for a new geometric layer is changed if necessary to ensure it is visible over the current View background color.
    • Label font for vector objects defaults to last-selected font if not previously set.
    • Rendered vector polygon borders do not include dangling interior lines.
    • When converting a style script to a style table, option to produce a related-only table suitable for legend generation by specifying a database key field.
    • Vector polygon layers can be set to show only dynamic labels by setting polygon styles to have fill only (no borders) and disabling polygon filling in the Vector Layer Controls window.
    • A redesigned Assign Styles by Attribute window integrates style editors and provides a variety of new features:
    • Redesigned Assign Styles by Attribute window with integrated style editors.
    • Automatic style assignment for manually-created styles with same name as the corresponding element attribute.
    • Insert individual styles from other geometric objects.
    • When select style object from another geometric object, styles are automatically embedded with the target geometric object.
    • Element-specific controls for automatic style generation.
    • The last-used automatic style generation settings are retained.
    • Automatic style generation for points allows selection of custom geometric and bitmap symbols.
    • Automatic style generation size controls provide option to specify scale (design, user-defined, or none).
    • Option to specify "none" for fill style and/or border style when automatically generate polygon styles.

    Marking Geometric Elements

    • Use Mark by Query icon button on the View window to open the Query Builder.
    • Designate which database tables are opened by default when geometric elements are marked. TechGuide
    • Double-clicking using the Select tool automatically zooms the View to the extents of the active element.
    • Optionally apply query only to currently marked or unmarked elements.
    • A query that does not match any elements unmarks any previously-marked elements.
    • Mark all elements adjoining currently marked elements.
    • Mark polygons with centroid inside or outside of a region.
    • Set View option to automatically zoom the View to the extents of the active element when stepping through a set of marked elements (Options / Zoom when traverse marked elements).
    • The Internal Element Details window for the active element (opened from the layer right mouse-button menu) provides option to Save as Text
    • Script Reference window for Query Editor provides predefined variables for current layout, group, and layer.

    GeoToolbox and Region Operations

    • Redesigned Region panel with integrated region combination controls. TechGuide
    • Use a set of marked geometric elements for measurement, generating profiles, creating a region, or adding to a sketch. TechGuide
    • Use extents of a displayed layer or group for measurement, adding to a sketch, or saving as a region. TechGuide
    • Choose to automatically open the GeoToolbox after creating a new region.
    • Choose the coordinate reference system to use when saving a region.
    • The Region panel can be active when the GeoToolbox Select tool is active.
    • The Manual panel allows saving the coordinate list for a drawn feature as a text or comma-separated-values file.
    • The Manual panel provides format choices for entering Latitude/Longitude coordinates.
    • Sketch changes are immediately saved automatically.
    • If a tool has been used to update contrast for the drawn area, clearing the tool and pressing the Update Contrast button recomputes contrast using the full raster area.
    • Perform region combinations using more than two regions at a time.

    Raster Display Layer

    • Set default auto-contrast method to use for rasters with no saved contrast table (on Raster tab of Options window opened from Display Manager / Options / View Options).
    • When a contrast table is saved, it is set as the default contrast method for the raster.
    • When a new contrast table is created for a raster layer in a layout, its use is set and saved in the layout.
    • Explanatory ToolTip added to the icon(s) shown for the components of a raster layer when expanded in the Display Manager.
    • Optionally choose to invert continuous color-scale and color-scale range legends.
    • Theme Mapping: specify number of decimal places for range labels in Theme Map Ranges legend.
    • Optionally choose to use the transformation model saved with the raster's georeference to control its display geometry (Use Saved Model toggle on the Raster Layer Controls window Object tabbed panel).
    • Set default use of saved transformation models on Raster tabbed panel of Options window (opened from Display Manager / Options / View Options).
    • In 3D display, choose to ignore terrain layer and render raster layer flat (toggle on 3D tabbed panel of Raster Layer Controls window).
    • Metadata stored in at the file level in multicomponent TIFF files can be accessed via the Metadata Editor when any of the raster components is selected.

    Raster Histogram Window TechGuide

    • View superimposed component histograms for color-composite rasters or RGB separates display layers with choice of which components to show.
    • Optionally show mean, median, standard deviation, and/or count on histogram graphic panel
    • Optionally show cumulative histogram.
    • View raster object properties on Properties tabbed panel.
    • Save snapshot of histogram graphic to PNG, TIFF, JPEG, or JPEG2000.
    • Option to compute full histogram if sampled.
    • Use only the actual cell value range for the histogram graphic for 8-bit and 4-bit rasters.
    • Show histograms from 64-bit and 128-bit complex rasters.

    Layouts and Saved Groups

    • Redesigned Group Settings window. TechGuideTechGuide
    • Set page size, page orientation, margins, and layout scale in redesigned Layout Settings window. TechGuide
    • Page size settings are automatically saved with the page layout.
    • A0 media size can now be selected.
    • Replace missing layers when loading a layout.
    • Project Files containing previously located missing objects are automatically searched for additional missing layers.
    • Add provided compass graphics using the Display Manager's Add menu.
    • In a tiled layout, specify the number of rows and columns and the order of groups in the Layout Settings window.
    • When switching from display layout to hardcopy layout, a best-fit scale is automatically set.
    • Set layout name to be shown in Display Manager list instead of object name.
    • Option to set default attachment for new groups as "geographic" for display layouts and page layouts (using Options / View Options from the Display Manager).
    • Stereo settings are saved with layouts and groups.
    • A 3D group added to a layout automatically uses the previously saved viewpoint settings.
    • A warning is shown in the Group Settings if create circular attachments between groups.
    • The placement tool provides the option to show only the active group's outline in the View.
    • Open single-group atlas as a layout with HyperIndex tools.

    Map Grids TechGuide

    • Choose which sides and corners of map have map grid labels.
    • Set vertical grid labels to read downward/upward or have tops inward/outward from sides of map.

    Printing TechGuide

    • Open Print dialog from an icon button on the Display Manager toolbar.
    • Redesigned Print and Print Setup windows with streamlined main settings on one panel.
    • Page size and orientation settings have been moved to the Layout Settings window.
    • Layout print and snapshot print retain separate default printer setting.
    • Automatic prompting for file name when print to file.
    • Warning shown if printing to existing file.
    • Choice of 72 dpi or 96 dpi resolution when printing to PDF.
    • Select from predefined page sizes when printing to TIFF.
    • Use CMYK color model when printing to TIFF.
    • Several compression options provided when print to TIFF.
    • Select printers with Kanji names.
    • Option to print to a raster in a Project File in full color or dithered.
    • Option on Colors tab to reset to defaults.
    • Stereo settings for anaglyph stereo printing are separate from those set for on-screen viewing. TechGuide

    HyperIndex Navigator/Linker

    • View window status line shows link description when the mouse cursor is over the link.
    • Change the order of the items in the HyperIndex list.
    • Create links to saved groups.
    • Set up links to execute encrypted as well as unencrypted SML scripts.
    • Set the description for a link by attribute from a database field.
    • When linking by attribute, if the element has multiple records attached, the list of records is shown to allow one to be selected.
    • When using Auto-Add to generate index areas automatically from geographic extents, user is prompted to specify scale and positioning.
    • Position and scale choices are disabled if linking to a file or URL.
    • The Previous View list is reset after performing HyperIndex navigation.
    • When linking to a single object, the object description/name is set as the default group name.
    • The Show Hidden Index Areas menu option (View / Options / HyperIndex) is inactive if the Show Index Areas option is turned off.

    Render To

    • KML: option to combine elements by attribute to simplify Google Earth legend.
    • KML: elements are sorted alphabetically by element name.
    • KML: specify precision of coordinate values by number of decimal places in addition to spatial accuracy.
    • Raster: option to render entire display or area of any open View.
    • SVG: filled polygons with simple border style are rendered as single path for polygon and border.
    • SVG: redundant text style descriptions for labels are not duplicated in the SVG files.
    • Tileset: allowed without requiring P15 printer support.

    Enhanced Support for EPANET Pipe Networks TechGuide

    • Create new vector objects in the Editor with full EPANET database schema.
    • Set up EPANET database schema for existing vector objects using new process (Database / Setup Schema).
    • EPANET Schema setup automatically creates and populates element ID tables and links them to EPANET tables.
    • Import of EPANET INP file parses grouped attribute data into different database fields for easier editing and allowing relationships between tables.
    • Improved EPANET schema creates optimal relationships between attributes in different tables.
    • EPANET INP file import warns when an element cannot be imported due to lack of coordinates.
    • Node Type and Link Type tables are created automatically to allow identifying pipe network elements and automatic styling by CartoScript.
    • Run EPANET hydraulic simulations from vector objects in TNTmips using new process (Geometric / Compute / EPANET Simulation).
    • EPANET Simulation process prompts user to populate database fields with missing mandatory attributes.
    • Export vector to EPANET INP file.
    • Option to export vector with control point georeference to EPANET INP using map coordinates.
    • Elevation fields in Junctions and Tanks tables are set as computed fields deriving their values from the "z" field in the internal table for nodes.

    Database Tables / Operations

    • Set up an EPANET or S57 database schema for an existing vector object using new process (Database / Setup Schema).
    • When creating a new record for a table with one-to-one attachment, a new record is automatically created for all marked elements of that type. TechGuide
    • Table view title bars now list the table name first so it remains visible if the window is narrow.
    • Use Table Properties window to set a table as hidden. TechGuide
    • Set default values for numeric fields in new records using field constraints. TechGuide
    • Populate a field in database table records attached or related to geometric elements by copying values from a field in another table attached or related to the same geometric element type. TechGuide
    • When a related-only table (such as a style assignment table) is copied via Add Table, field relationships are automatically set if the related table and field exist in the destination data, making the copied table immediately usable for styling.
    • Floating-point fields allow showing a maximum of 15 decimal places.
    • Improved status bar messages in single-record table view.

    Editor

    • Use Marked Elements icon menu to copy or cut marked elements to clipboard.
    • When adding elements, simply select a record in an associated database table view to be assigned as the default record for each new element. TechGuide
    • Set up Database Prompts for node tables in addition to other element types. TechGuide
    • When creating a new vector object, set option to automatically convert nodes to points to enable assigning node attributes.
    • Editor controls updated to include new Region Manager interface.
    • In Auto-Generate Labels operation and setting label text by script, can use "return" keyword to set the string or string expression to use.
    • Create new vector objects with S57 or EPANET database schema.
    • Topology type automatically set to Network for new EPANET vector objects.
    • Nodes automatically converted to points for new EPANET vector objects for attribute assignment and styling.
    • CartoScript styling for lines and nodes is set by default for new EPANET vector objects.
    • Vector Validate operation reports total time to validate.
    • A warning is shown if the coordinate reference system (CRS) of the active editable layer differs from the group CRS set by a reference layer, with option to change the group CRS to match.

    Georeference

    • Terrain layer added using Set Z from Surface button is automatically added as the bottom layer in the Georeference Input View.
    • When using Rational Polynomial model, RPC coefficients are automatically read from DIMAP file for Pleiades satellite images.

    Image and Raster Operations

    Apply Contrast and Match Contrast TechGuideTechGuide

    • Apply contrast and match contrast using color-composite rasters.
    • Apply Contrast produces 16-bit output raster from 16-bit input raster.
    • Apply Contrast saves a default linear contrast table with the result so it displays as produced.
    • Match contrast of multiple images to the same reference image.

    Mask Editor TechGuide

    • Process window redesigned with more compact and intuitive layout.
    • Fast display and processing even for very large rasters.
    • Create mask or null mask and save to multiple matching rasters such as image bands.
    • New Mark from Edge tool selects all cells of specified value(s) contiguous with edge of raster.
    • Use numeric filter settings to restrict selection to a specified numeric range when marking by drawing or by region.
    • Icon ToolTips provide more informative descriptions.
    • Uses new Region Manager interface.

    Spatial Filtering

    • Larger display of filter kernel on the Kernel panel.
    • Maximum kernel size increased to 100 x 100.
    • Add input rasters without replacing current selection.
    • Auto-name option added for multi-raster output.
    • Choose pyramid type and compression for output.
    • When filtering by area, a message prompts for a right-click to accept the selection area.
    • Filter code converted to use more efficient image pipeline structures.

    Miscellaneous

    • Compute Length-Slope factor raster in Watershed Analysis for Universal Soil Loss Equation.
    • Bing Maps and MapQuest public reference layers can be added to the Watershed View.
    • Choices for Scale and Orient options in Raster Resampling using Georeference have been clarified.
    • Feature Mapping prompts to save feature definitions separately from the Features raster only if an existing feature definition library has been opened.
    • RPC Orthorectification in Raster Resampling reads RPC coefficients from DIMAP format for Pleiades satellite images.

    Import / Export

    • Import formats that are not supported on the current platform are shown in the Import list and provided with an explanation when you try to use them.
    • Display and use ESRI File Geodatabase 10.0 in its native form, import as vector or CAD object, and export TNT geometric objects to File Geodatabase. TechGuide
    • Display and use ESRI Personal Geodatabase 10.0 in its native form or import as vector or CAD.
    • Display and use a number of additional geometric file formats in their native form or import to vector or CAD objects: ArcInfo E00, Coverage, and Generate
    • Import Microsoft Access MDB files in 64-bit TNT (requires OLE DB Provider installed with the free Microsoft Access 12 Database Engine).
    • Import Microsoft Excel XSL files in 64-bit TNT ((requires OLE DB Provider installed with the free Microsoft Access 12 Database Engine).
    • Import Microsoft Access ACCDB files (Microsoft Office 2007 & 2010
    • Import Microsoft Excel XLSX files (Microsoft Office 2007 & 2010
    • Import of GPX files supports polyline and polygon elements, database records, and Garmin's GPX extension.
    • SPOT6 import from JPEG2000 automatically reads georeference information from accompanying XML file in DIMAP format.
    • Import raster objects from or export to Arc/Info floating point binary format.
    • Export TNT geometric objects to GeoRSS, GeoJSON, GMT, and Atlas BNA.
    • Database import defaults to UTF-8 encoding.
    • The last-used path is stored when export to any file format lacking a predefined file extension (e.g., raster simple array).

    Export Geometric Tileset

    • Specify source for info window name and description from database fields or from DataTip.
    • Choose from a range of geometric tile sizes that are automatically accommodated in geomashups.
    • Element type toggles are individually enabled/disabled based on available elements in input vector object display settings.
    • Choose whether to save a copy of JavaScript library with the geomashup or provide a URL to library web location.
    • A tileset statistics report is automatically saved with the reference data.

    Export, Mosaic to, and Subset Image Tilesets

    • Google Earth KMZ target: if file size and count exceeds limits for KMZ, tileset is created as uncompressed Google Earth KML super-overlay.
    • A tileset statistics report is automatically shown at the end of processing or written to a log file if using Job Processing.
    • Last-used contrast table is automatically applied to grayscale input raster and for multiband RGB input.
    • Improved label for option to create full pyramid of levels in KML super-overlay structure.
    • Subset Image Tileset provides option to convert tileset structure (e.g., Google Maps to Google Earth).
    • Save subset tileset directly to Android device for viewing in Google Earth app. TechGuide

    Export, Mosaic to, and Subset Terrain Tilesets

    • Mosaic to terrain tilesets.
    • Subset (extract from) terrain tilesets
    • Set elevation units for tileset from input raster information if available.

    Assemble Geomashup

    General

    • Set option to automatically close any info window when a new one opens.
    • Set option for geometric tilesets for element click to go to a URL to open a web page in the browser instead of the info window.
    • Set option for geometric tilesets to include/exclude element selection checkbox controls for legend samples.
    • Improved layout control and resize behavior for custom sidebars.
    • Option to set minimum width and maximum width and height of info windows.
    • Simplified choices for creating sidebar with drawing tools.
    • Option to add a logo graphic over the map area and set its position.
    • Option to access Google Earth historical base images.
    • Google Maps: show KML text points as labels.

    Expanded Support for Open Layers

    • Use geometric tilesets (SVG, SVGZ, KML) with attributes shown in info windows.
    • Use WMS layers.
    • Add legends for geometric tilesets with controls to turn individual classes on/off.
    • Use checkbox and radiogroup controls separately or in combination.
    • Add custom sidebar content.
    • Set info window sizes for both KML and SVG geometric tilesets.
    • Add measurement or drawing tools.
    • Use MapQuest aerial imagery and roads layers as basemaps.

    Geospatial Scripting

    • Encrypt SML script files in addition to script objects in Project Files.
    • Encrypt scripts using Encrypt To menu options separate from Save / Save As.
    • Encryption procedure automatically prompts for a description to be shown when the script is opened in the SML Editor.
    • Encoding type is set to UTF-8 by default when saving scripts.
    • CartoScript: a GroupAngleRadians value (Script Reference / Constants) allows script to use the rotation angle that has been set in the Group Settings window.

    ToolScripts and MacroScripts

    • GRE_LAYER class includes UpdateExtents method.
    • GUI_GADGET_POLYLINE class provides method to set default edit mode for tool.
    • GRE_VIEW class includes ActiveTool member for getting and setting the active tool.

    Miscellaneous Process Features

    • Lidar Classification: Change reports show time and date of previous and current classifications.
    • Geometric Extract: Option to extract by polygon using a vector object as region.
    • Vector to Raster Conversion: a null mask is automatically created for the output raster with areas outside the vector elements set as null.
    • Contact Support Form: pressing the Capture Movie icon opens a message explaining the procedure.
    • Color palettes: ToolTip shows color values for each color sample.
    • Color Editor: enter percent color values (RGB, HIS, CMYK) accurate to one decimal place.
    • Help windows include button to search web documentation for the current topic.

    New Coordinate Reference Systems and Components

    • WGS84 / Antarctic Polar Stereographic Coordinate Reference System
    • Finnish ETRS-GKn (N=19-31) Coordinate System
    • Japan JGD2011 Datum
    • Nepal Datum
    • Vietnam 2000 Datum Transformation
    • Rename or delete user-saved coordinate reference systems.
    • Selection window allows choosing coordinate reference system from an existing object.